This requires an intermediate skill level.

Installing unstable software, can cause your system to crash. This is NOT recommended for n00bs. The how to add the ppa’s are contained in the link below. But again, if you don’t know what this is: DON’T DO THIS, unless you are sure.

PPA for Firefox / Thunderbird Versions 5/6/7/8

Version 3.X of Firefox kills my Ubuntu 10.10 (AMD 64) System. But version 6 and beyond run fine.

This is what Thunderbird V 5 looks like:

Thunderbird Version 5

Thanks again, Joe.

Wayno